Back to overview
Degraded
Admin Dashboard Unavailability
Mar 16, 2026 at 10:07am UTC
Affected services
Dashboard
Resolved
Mar 16, 2026 at 10:29am UTC
We’ve identified the root cause of the issue and resolved it. Thank you for your patience while we worked through this.
Affected services
Created
Mar 16, 2026 at 10:07am UTC
Some customers are reporting that the admin dashboard is unavailable. We are currently investigating the issue and will keep you updated.
Affected services